I'm unable to put on my gas mask in Moscow? Metro 2033?

  1. I've tried restarting, using a different user profile and checking disk. I'm unable to don my mask when going above ground to Moscow, using the down control pad. I've even tried changing the control configuration and trying. Also, I did buy 2 filters at the Market. Mask just won't go on. Even if I hold the down pad or tap tap tap it. Any other suggestions? Btw, I was able to put it on at the beginning with both profiles.

    User Info: quincy1dog

    quincy1dog - 7 years ago

Answers

  1. The down button on the d-pad is a known glitch, you just gotta keep trying and it should work if you havent down so already get the game update when you log onto xbox live and that should fix the issue.

    User Info: couger81

    couger81 - 6 years ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.