Anyone know what causes the buying a home in Windhelm bug?

  1. I've sided with both imperial and stormcloaks and each scenario i encounter the bug. I figure there is no way to fix the bug on 360 but i'd like to know what causes it so i can plan a ahead next playthrough. I'm wondering if maybe it is caused by that one Dark brotherhood quest, or maybe i just missed the crowd when the dead body shows up in the graveyard.

    User Info: Rhaegar8374

    Rhaegar8374 - 7 years ago
  2. What exactly is the home in windhelm bug?

    User Info: sora_V2

    sora_V2 - 7 years ago
  3. Well it's a bug that doesn allow you to buy the house in windhelm OR do the blood on ice quest, reason i know its a bug is cuz it's mentioned a few times on wiki. Well i did do the blue palace quests before realy delving into any windhelm quests. And i did the greybeards quest before the civil war, maybe the peace treaty quest messed things up cuz a few jarls got replaced.. i waited to join any sides until i was done with all guild/faction quests and main story... i guess im just hopin some people who have had same problem as me see this an relate their problem with the bug. Oh and i didnt have ANY problems with Rolaf at fort Neugrad. Ive also read about problems getin the house in Solitude if youve already helped 5 out of 5 people when gettn the thane quest in solitude, i didnt have that problem in solitude but i did in windhelm.

    User Info: Rhaegar8374

    Rhaegar8374 - 7 years ago

Accepted Answer

  1. I've read, and tried, that you can wait outside Windhelm until around 2am or so then enter. Head over to the cemetery then you'll see everybody around the body. That's how it worked for me.

    Note: Not sure if you're aware of the house's weapon rack/plague glitch, but when you buy all the stuff for your house, save beforehand and when you enter your house and the plaques don't work, then quit to the main menu and load your auto save of when you enetered.

    Also, don't put staffs in the display cases, they vanish without a trace lol.

    User Info: Mr_Rawr

    Mr_Rawr - 7 years ago 0   0

Other Answers

  1. Ummm i'm not sure if this has anything to do with the glitch... cause i'm getting it too right now...

    I sided with the imperials... and when I went to Windhelm to buy a house there, I noticed all the jarls that supported Ulfric were sitting around the table... I kinda found this odd and I wonder if it has anything to do with this glitch.

    User Info: dalmunae

    dalmunae - 7 years ago 0   0
  2. You only get to buy the house in solidute if you do the blue palace quests.
    If you haven't done the greybreads. do that. The council meeting between the two sides, fixed the bug for me with ralof in the fort where you resuce him. his dialoge was stuck

    try the dragonborn quest if you havent

    User Info: skyrim1991

    skyrim1991 - 7 years ago 0   1

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.