"A Brother's Roast " Shrine Quest glitch. Anyone else?

  1. Hi all,

    I've beaten Ganon, got all the 119/120 shrines, including the completion of 41/42 shrine quests.

    However, I have skipped the "A Brother's Roast" shrine quest because whenever I go and talk to the angry Goron (Bladon) who's looking for his bro to start the quest, the quest's logo appears on screen but can't be activated as the active mission from the menu, which is related to the main problem.

    The problem is that if I talk again to the same Goron (Bladon) after the first time, Link'll enter the conversation mode with no text on the screen whatsoever, and the only thing that can be done is rotating the camera with the right stick, absolutely nothing else!

    That leaves the sole option to resume the game afterward as to force-close the game from the Switch's home screen, then start again.

    I've tried loading and not talking again to the same Goron, then I went to his missing brother in the cave but I can't even talk to him at this time!

    The weird thing is that he isn't digging anymore and he's just standing there not doing anything but stare at me!

    What is supposed to happen is that he should be laid on the ground, I talk to him then his bro (Bladon) will arrive there after me, then he'll ask me to grab one of the roasted rocks from down the cliff, where they don't spawn unless this conversation happens (I've tried).

    Now, is there something to do to work around this weird glitch?

    My system's version is 9.0.1. The game is updated to v1.6 and has the 2 DLCs.

    It's sad to not be able to finish the game after all the spent time and the effort, I hope someone can help.

    Thank you

    User Info: Barrytoo

    Barrytoo - 1 week ago

Answers

  1. Hmm, It sounds like there could be some corruption in the Data. I would recommend uninstalling (Deleting Updates/DLC and game data, NOT SAVES) And then doing a clean install of the game from the disc and having it install the Updates and then Install the DLC manually. Or Re-Download and install if it was bought online.

    User Info: Lunatic_Dorg

    Lunatic_Dorg - 3 days ago 0   0
  2. Tried all of that and didn't work. The weird thing is that there's another account playing the game and didn't have the same issue!

    This tells me that it's an in-game issue due something that I have done while the other didn't, like the order of completed missions.

    User Info: Barrytoo

    Barrytoo - 3 days ago
  3. What you mentioned doesn't seem related to the problem. If you have a solution, I hope you can clarify further.

    User Info: Barrytoo

    Barrytoo - 1 week ago 0   2
  4. Well Idk about any glitch but the moblin or Majora's mask will work

    User Info: DerpyCappy64

    DerpyCappy64 - 1 week ago 0   3

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.