Is Yontek glitched for anyone else in Fool's Gold?

  1. I'm on my first playthrough with the W3 complete edition. I'm under level, only level 6, almost 7, however when I ran ahead to kill the Nekkers as Yontek and the pigs head to the temple, I died to the warrior Nekker thing twice and had to reload. When I came back the third time, I killed the warrior and Yontek took off running, I followed assuming the pigs were as well. Welp. They weren't. Now he's just standing at a fork in the road by the hidden treasure buildings, although I am able to speak to him, he only says "It's done! We can go." and just stands there. Failed quest triggered when I went off looking for the pigs and he disappeared. Had all 9/9 pigs. Loaded save. Waited forever and still no pigs. Is this bugged or what? Not sure what to do. Loaded the autosave but still nothing. Bad habit of not manually saving frequently enough (something I should be better at after DA:I). Any help would be greatly appreciated.

    User Info: IOnlyKissGirls

    IOnlyKissGirls - 4 weeks ago

Accepted Answer

  1. There were a number of issues with the quest when it was first released, but those seem to have been fixed with patch 1.08. You may need to download that patch. If you got the quest from Lurtch in Velen and you have the patch then you may have another glitch. In that case you may be better off posting a topic on the message board where more people will see your question, which will improve your chances of getting more help. In case you need it, the message board link is usually the last quick link in the bar above the question that has links to Home/Guides/Q&A/Trophies/Reviews/Media/Board. Another benefit of posting on the message board is that we can post a direct link to off-site help such as a youtube videos. Good luck!

    User Info: chaoyun2k

    chaoyun2k (Expert) - 4 weeks ago 1   0
  2. I play on PS4, I thought I'd mentioned that but like manually saving, it slipped my mind. Lol Thank you, I have never posted before so I didn't know about any of that. I am a bit...blind if you would, and didn't notice there was a checkpoint save I could load just before the Nekkers area. So, problem solved. Still, was a weird bug or glitch that I couldn't find anywhere else on the internet. I might post it where you suggested so if perchance anyone else happens upon such an issue, maybe they'll be able to get help for it if they don't load a checkpoint. Lol Thank you for your help, I appreciate it. :)

    User Info: IOnlyKissGirls

    IOnlyKissGirls - 3 weeks ago

Answer this Question

You're browsing GameFAQs Q&A as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.