Missing Cosmo Memory and I have absolutely no idea why?

  1. I'm at endgame, like not much left to unlock before Sephiroth and the WEAPONs. I followed 2 different missables guides religiously. I have Vincent and Yuffie. I finally bothered with unlocking Red's limits. I know with 100% certainty that I had Cosmo Memory at one point. I have not discarded it and I don't know if it can be stolen. I feel like my plan to 100% the entire game is crumbling to dust before my eyes. Help...?

    User Info: YamishiAndMizu

    YamishiAndMizu - 3 days ago
  2. Additional info: I'm on Switch and I've tried sorting. It's not next to Barret or Aerith's limit breaks in my inventory.

    User Info: YamishiAndMizu

    YamishiAndMizu - 2 days ago

Top Voted Answer

  1. An item can only be stolen if it can be sold in shops (and 4th Limit Breaks Manuals can't be sold). Try arranging items by "Type", if it still doesn't show up, you've either discarded, or even failed to collect it as battle spoil.
    Maybe it's possible to dig for it at Bone Village, that location offers chances to find some items player failed to collect.

    User Info: SuperVergil

    SuperVergil (Expert) - 3 days ago 3   0

Answers

  1. Cosmo Memory cannot be discarded and it cannot be stolen or sold in shops. Once you have contained the Cosmo Memory the only way it can be removed from your inventory is to teach the Lv 4 Limit Break Manual to Red XIII. If you have obtained Vincent then you will have had to have killed Lost Number, which means that the Cosmo Memory has to be in your inventory.

    As SuperVergil points out - try arranging your items by "Type" and scroll down to see if it's there. You can not dig up Cosmo Memory from Bone Village.

    User Info: DynamixDJ

    DynamixDJ (Expert) - 2 days ago 2   0
  2. If you cant find it in Bone Village than the Black Chocobo Save Editor is good for situations like this. BUT that depends on the platform. What platform have you been using?

    User Info: PlasmaZERO

    PlasmaZERO - 2 days ago 1   0
  3. I'm on Switch, for clarification. I've also sorted my inventory several times by type, it's not next to Barret or Aerith's limit breaks in my inventory.

    User Info: YamishiAndMizu

    YamishiAndMizu - 2 days ago
  4. I know this may sound like a dumb question, but are you 100% sure that you haven't taught it to Red XIII? if it;s definitely not in your inventory then the only remaining explanation is that Red already has the Limit Break.

    It's pretty much impossible for an item to simply disappear from your inventory; no glitch of this nature has ever been documented

    User Info: DynamixDJ

    DynamixDJ - 1 day ago
  5. I only just started learning his limits, after some work I unlocked every limit other than his ult. This is after a lot of grinding at northern cave. I checked a save right before the end of disc 1 and it's not there either.

    User Info: YamishiAndMizu

    YamishiAndMizu - 1 day ago

Answer this Question

You're browsing GameFAQs Q&A as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.