Question Details

  1. Okay, I've downloaded a Sim from the Exchange into my launcher and went to install it, with no issues. Loaded up the game, went into CAS and he wasn't there. Quit the game and re-opened the launcher, and the Sim appears in the launcher as if it hadn't been installed. Tried again, same result... several times :/ I refuse to do a complete uninstall, having played a total of around 1600 hours (according to Origin) and desperately want to keep my progress... please can anyone help? I'm not very tech-savvy, so want to avoid poking around files in case I break something.

    I have all stuff and expansion packs installed and a large quantity of Store items, although I mostly avoid mods. My game runs perfectly fine, but this is starting to get under my skin.

    User Info: Shiu-shara

    Shiu-shara - 1 year ago

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.