Help, I'm trying to get into Nexus but it won't let me, what is going on?!

  1. I had been going to Nexus since I bought my PC about two years ago, a month ago I tried to enter again but an error message was shown saying

    Error
    The site has run in to a problem, please look at the error message below...

    You must be logged in to use this feature

    It keeps saying that! But then every time I try to log in it says " 's Account" Literally, it just says 's account! Then when I tried to log off it just kind of refreshes the page and it says the same thing, it doesn't log off or show me mods, it just refreshes to show the exact same thing again!
    If you wonder why I didn't ask before it's because I've tried to see if anyone has the same problem as me but apparently I'm the only one.
    Again, please help me!

    User Info: Thorinstormblad

    Thorinstormblad - 3 years ago

Accepted Answer

  1. I had a quick search about this on Nexus, and for most of the people who had this issue, it resolved itself after a day or so. Are you still experiencing this?

    User Info: Celtickitty

    Celtickitty - 3 years ago 1   0

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.