Skyrim launcher looping, cannot play (on Steam)?

  1. So I wanted to play Skyrim on a different PC. Downloaded Steam, installed Skyrim, but now whenever I hit "play" on the launcher menu it just asks me to give it permission to make changes to the computer and whatnot, then the launcher menu pops up again.

    I tried:
    1. Verifying Integrity of Game Cache
    It just says that "1 file failed to validate and will be reaquired" but doesn't download anything. I looked up this problem but can't seem to find any solution. However, on the Steam support website, it says that this might be because "Saved game files that would cause game progress to be lost if verified". It might be this because I accidentally deleted a save on my other PC while I'm offline. I panicked and deleted Skyrim from that PC and didn't touch it again on that one in hope that I might be able to get the file back using the Steam system. (later I gave up and told myself to deal with it lol). So maybe this is why it doesn't validate my file, but if this is causing my game to stop working then I'd rather lose that save than not be able to play it again.

    2. Giving myself administrative rights to the file. Well, I think I did.

    3. Using Skyrim SKSE - but it tells me I need to run it as an administrator, which I did, but it still doesn't work.

    And by the way, I have no mods or DLCs.

    User Info: Night-Wolf

    Night-Wolf - 4 years ago

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.