How do I get past Palace after meeting with Yago?

  1. Met Fleece, went through sewers to palace, found Yago, can't leave.

    User Info: JES62

    JES62 - 9 years ago
  2. I've had this issue as well. I can see the doors to the palace, and there's a yellow bar that indicates it's an exit, but I can't get it to trigger leaving the palace no matter what I do. I talked to Yago, I saw the cut scene with the king and the lady in white, and I snatched that ring for Flece, what else is there to do? Is it a bug?

    User Info: trejodunesea

    trejodunesea - 9 years ago

Top Voted Answer

  1. It is most likely a bug, the game has quite a few strange little glitches like that.

    User Info: LandonRay

    LandonRay - 9 years ago 2   0

Answers

  1. This Youtube User I Think Fixed It:ulastara. And Tell If You Contact Them How They Fixed It I Want To Know Too.

    User Info: Josepsh

    Josepsh - 6 years ago 1   0

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.

More Questions from This Game