Question Details

  1. I'm in the room with Snaking trying to rescue Amidala and Jar-Jar. I pulled out the first generator but can't manipulate the other two. Any suggestions?

    User Info: vrynex

    vrynex - 8 years ago
  2. I've tried pulling them out, i approach them but they stay non-interactive. I've also tried restarting the mission hoping it helps, but nothing.

    User Info: vrynex

    vrynex - 8 years ago

Accepted Answer

  1. I've noticed this room is really finicky. The grapple one shouldn't give you any trouble, but the other two are so incredibly picky.... Anyway. Drop into the hole in the floor, walk up to the first green block until you're pushing yourself against the wall. Now press and hold A; if you're in just the right spot, you can see your character put up his hands like he's gripping the block. Keep holding A and press down on the D-pad to pull it out. Use the Jedi Jump pad to go up to the second one, and it's just as fussy as the first one. You've got to stand in just the right spot and again press and hold A the whole time.

    User Info: ghostrider9876

    ghostrider9876 - 8 years ago 0   0

Other Answers

  1. First generator - in the floor. Use force to move the grate out of the way then pull out generator.
    Second generator - use force jump to get up to it. Pull out generator.
    Third generator - from the second, use the force to break the glass tubes. Jump across to the platform and you'll see a clone trooper platform. Use clone trooper to pull out last generator.

    Hope this helps.

    User Info: zebag

    zebag - 8 years ago 0   0

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.