• Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.

User Info: dawnnoob

10 years ago#1
It seems my other topic was closed because it was considered "trolling" or w.e anyways here's another way to help you guys out

By mechlink

Hello community, first off me and my friends have had Black OPS from first day and just in the last few weeks we have been running test on our routers, modems, PS3's setting to see if we can improve or stabilize Black OPS online Play.
We have been testing on 5 PS3's and using DSL and Cable internet all at 1.5 meg to 8 meg connections and less than 28ms ping, tested on www.speedtest.net , 3 of the PS3 are in Texas, 1 is on Florida and the one is in Canada.

PS3 models used in test and connection data:
PS3 40gig x2 / AT&T DSL 3meg = 1 wired, 1 wireless connected to router
PS3 60gig (original first series) / AT&T DSL 1.5 meg = wired connected to router
PS3 80gig / AT&T DSL 1.5 meg = direct connect to modem
PS3 320gig (with move bundle) / Cable 8 meg = wireless connection to modem

All the PS3 on DSL but one showed NAT type 2 the other showed type 3 when you run the the PS3's connection test but Black OPS shows Strict NAT when in the game, and the same test where run before and after the 1.04 patch.
we fixed the one on type 3 by bridging the DSL modem and running PPPoE on the router.

PS3's on cable show NAT type 1 and 2 depending on the router settings, and Strict or Moderate NAT type in game.
enabling UPnP on the router changed it to NAT type Open (why is was off I don't know)

If you are using a Motorola 2210 or Netpia DSL modem's (both the same modem) then you are going to have problems with your NAT type especially if you are connected to the modem through a router, if you are using a DSL gateway (Router/DSL moddem all in one) then you can simply change a few setting like UPnP Enabled and Firewall settings to fix the NAT.

If you are connected the the modem through a router enabling UPnP on the modem and router will help and setting Static NAT on the Modem fixed one of the PS3's NAT types to Moderate (this PS3 was on wireless connection when we put it on wired it went to NAT type Open),

We fixed the other by turning on Bridge mode ON for the modem and running PPPoE on the router.
NOTE: only someone knows what they are doing should try bridge mode and you don't need to run bridge mode if you are connected directly to the modem,
if you have a Motorola 2210 DSL modem here is a guide on how to bridge it , http://www.dslreports.com/faq/15817 (try at your own risk)

We tested on Linksys, D-Link and Netgear routers. Linksys and Netgear routers did the best the D-Link had way to many problems.

Wireless connection shows Moderate NAT in game most of the time, sometime is shows it open, I recommend a wired connection if you can.

Basic setting to check on router and modems:

1. UPnP is ENABLED on the router or modem if that is what you are connected to

2. Opening the ports on your router for the PS3
Playstation Network Required Ports
TCP 80
TCP 443
TCP 5223
UDP 3478
UDP 3479
UDP 3658

3. Check your routers or modems firewall settings to make sure it is not set to high

Advanced setting to try:

1. Bridging your DSL modem and running PPPoE on router
2. turning off router setting "block anonymous internet request" (if this doesn't fix it turn it back on)
3. Make sure your Router and Modems Firmware is up to date
4. This fixed the problem on one of the PS3 you might want to try it

Please Run your PS3's connection test if it shows NAT Type 3 you need to at least have NAT type 2 on the test before blaming the game.
Psn- David_OS, Xyour-ambitionX

User Info: dawnnoob

10 years ago#2

Q: I tried some of the suggestion and I still have Strict NAT type in game but NAT 1 or 2 on PS3 test.
A: If you don't have this problem in other games then its most likely Black OPS not you

Q: Will having open or moderate NAT type fix the disconnecting problems?
A: Probably not that is on the game or server end but having a good NAT type like Open or even Moderate will help.

Q: Have you noticed any changes in having an Open NAT type vs a Strict NAT type?
A: Not with disconnecting problems but it is a lot better in game as far less lag and people seem to die like they are suppose to unlike
before when it took 20 shots to kill one person from behind when they were not even moving.

I hope this helps at least some people, if not I am sorry
Psn- David_OS, Xyour-ambitionX

User Info: dawnnoob

10 years ago#3

Hello everyone, im going to post a little guide or tutorial if you will to set up a static IP address for your PlayStation, and to set set your router to DMZ to your PlayStation.

Fixing your Nat is a simple process. It involves assigning a static IP address to your PS3, and the setting your router to DMZ mode forwarding it to your PlayStation's IP address.

First, to get a static IP adress on your PS3, you must know some of the information from your router. This requires a PC.

1) Make sure the PC is on and connected to the internet through your router.
2) Click the "start button"
3) Click "run"
4) Type: cmd
5) Click "OK"
6) Type (in the black window): ipconfig /all
7) You will see a long list of words and numbers.

Write down the following from the list:

Default Gateway
DNS Servers (only the first 2)
Subnet Mask
DCHP Server

Thats all you need from the PC for now. Double check your numbers and make sure they are correct.

8) Go into your PS3
9) Select Network Settings under the Settings Menu

10)Select Internet Connection Settings

11)Instead of choosing Easy, we will do things the complicated way. Press right until you get to Address setting, and then choose custom.

12)Go right until you get to the page that says" Select the operation mode of the selected device. and choose manual settings.

13) Now continue until you get to the page with all of the numbers on it (presets are all zeros)

Enter the information as follows

Enter your Primary DNS as the 1st DNS number you got earlier from your PC
Enter your Secondary DNS as the 2nd DNS Number you got from your PC
Enter your Default Gateway (linksys default was
Enter your Subnet Mask (linksys default was
To make it easy, use as the IP address

14) Go to the right (selecting all the pre-selected setting) until you get to the screen that says "press X to save" do so, and press "test connection on the next screen.

There you go, your PS3 now has a static IP address.

the Next thing you have to do is to go back on your computer and type in into your browser <--(this is linksys's default router ip address)

a screen will pop up asking you for your username and password. If you haven't changed the default username and password, then the default username will be: administrator and the password will be: admin

your router settings will then pop up. depending on what router you have and what firmware update you have the settings will look different.
for linksys router's you will see a tab that says "applications & gaming" select this tab.

Once you select this tab, you will then see another set of tabs under it, select the one that says DMZ.

On this page you will have to do 2 things. one, you will have to enable DMZ. The second thing you will have to do is under the destination type in your ps3's IP address that you just set up a little while ago.

if you are using some other kind of router, just look for anything that says dmz and then put your ps3's ip address in.

Now turn everything off that is connected to your router, once everything is turned off turn them back on and enjoy an OPEN nat type.

hope this helps
Psn- David_OS, Xyour-ambitionX

User Info: dawnnoob

10 years ago#4
posted by vahn-treyarch developer

If you are:

(1) one of those people who have reported that MW2 says the NAT is OPEN but BLACKOPS says the NAT is MODERATE
(2) you are using the "Start MP by Default" option
(3) have a UPnP router (as confirmed by the XMB connection test)
(4) network savy, are comfortable messing with routers
(5) are not wireless; you are using a hardwired ethernet cable
(6) are not currently port fowarding or DMZed, just trying to use UPnP like "most people" OR you are willing to temporarily change your router to not use that set up

-Disable the option to "Start MP by Default" so that you always boot through CAMPAIGN/SP. Back out of the menu so it saves.
-Shut down your PS3 entirely so it's off.
-Reboot your router entirely (either by unplugging it, reset switch, or by the Reboot button in the web admin panel [depends on router])

-Turn Router back on. Wait a bit of time till it syncs up/is booted.
-Turn on your PS3.

-Boot Black Ops into single player.
-Switch to multilayer
-Connect to PlayStation network so you see all 4 revisions numbers (52.X.X.X) in top right hand corner
-Go to Options
-Hit select
-Check NAT Type

Does it now say OPEN instead of MODERATE?

I am trying to validate if a timing problem occurs with the Nat Transversal/UpNP if you boot MP by default.

As always, cheers to those of you who keep it on topic. Your reply should be something simple such as:

-I meet the conditions you describe.
-These steps "did" or "did not" work for me.

Again, it's important to fully shut down and reboot your PS3 and router in-between, otherwise the test is not 100% valid because either the PS3 or the router could be remember the port mappings from MW2. I don't want it to. Although that might be a good work around for you, it won't help us valid the test. I am doing the same testing here although we are using Wireshark and a hub to see what is going on.

David 'Vahn' Vonderhaar

Update 1:
Be sure your router Firmware is up to date. Mine was not and UPnP started reporting as available in the XMB after I upgraded even though my router is a really newer Linksys model I bought just a few weeks ago!

Update 2:
Having an OPEN or MODERATE NAT is important. OPEN is best. I don't think the NAT issues are the one and only problem. We are investigating Quality of Service probe failures (Game Lobby closed) and much more.

If Black Ops is failing to properly open up the necessary ports on UPnP routers this could cause significant issues for a large number of typical Internet at home users. It's not just about your connection, but the connection you can maintain between everyone in your party, or in the game.

Update 3:
I have to do this every time I post, but so be it.

Most issues in the game can be fixed if they can be found and reproduced. I was finally (after upgrading my router firmware) able to reproduce the issue that people were telling me about where MW2 would report OPEN but BlackOps would report MODERATE.

I couldn't get this to happen because I wasn't actually UPnP enabled. I wasn't UPnP enabled because of a bug in my router firmware, not the game, that the manufacture later patched. Now that we were able to reproduce it 100% of the time we are able to attach a network capture device and figure out why.

Debugging isn't hard. Finding 100% reproducible cases can be hard when dealing with the huge variety and quality of Internet connection types and the dozens of router manufactures and firmware versions in use.

I continue to maintain that if we can get 100% reproducible cases, we can find and fix the problems.
Psn- David_OS, Xyour-ambitionX

User Info: dawnnoob

10 years ago#5
Update* Although I don't expect anyone to go out and purchase a new router just to play Black Ops, I did want to take a few minutes and share some test results.

Some users have reported that Black Ops will report something differently than MW2 with regards to NAT type. Some have reported that if they load MW2 first, then load Black Ops, the NAT will go from moderate to open.

This really got my attention because it would imply that Black Ops is not opening the proper game ports if your router is UPnP enabled (and many are, especially those from 3rd parties instead of the white label OEM versions that comes with your Cable, ISDN, or Fiber package).

At first, I could not reproduce the issue with my LinkSystem E3000 (a very common, and relative newish router). My NAT would always be moderate and the XMB would tell me that UPnP was "Not Available" even though UPnP was enabled on the router. So, I upgraded the firmware from 1.0.02 to 1.0.03.

After doing so, the XMB would report that UPnP was "Available." However, if I booted straight into MP with "Load MP by Default" option, the game would still report Moderate. If I turned that option off and went through the Campaign/SP menu, the game would report the NAT as OPEN, as it should.

We put Wireshark (packet sniffer, network logger) on the line. Sure enough, the request to open the necessary ports was being sent by Black Ops, however the reply was coming back during HDD read access and getting dropped by the PS3. This is a minor timing bug and can be fixed with more aggressive re-try attempts.

This also explains why some people could load MW2 and then load Black Ops. Your router was creating the same port mappings Black Ops wants to use. I was able to repro this after the firmware upgrade.

This solution won't open your NAT unless you have a UPnP router and the same timing issue I have. However, I was able to repro the problem, and the workaround (disabling the Load MP by Default) on a Netgear Range Max Wireless N 150 as well as my Linksys E3000. I have a feeling I could repro and work around on more routers.

Today I experimented with the following

-Linksys E3000
-Linksys E2000
-Belkin F7D8302v1
-Belkin F7D301v1
-Netgear Router Manager Wireless G WGR614v10 (with Wireless disabled)
-Netgear Range Max Wireless N150 Router WPN824N

Out of the box, ever single one of these routers has UPnP enabled and without fail, Black Ops would report as OPEN Nat when connected to them and the XMB would report that UPnP was Enabled.

In fact, I turned off UPnP on all of them so I could get more moderate Nats in my test case. Only the Linksys routers worked as I expected they would and turn Black Ops back to Moderate NAT if UPnP was disabled.

Both Belkins and both Netgears would report that UPnP was not available in the XMB, but Black Ops would report the NAT as open. I suspect this is because they cache the port mappings. I have them powered off over night, and will look again at them tomorrow morning.

To be super clear. I am not using wireless in any of these tests and have the radios turned off on the routers entirely. I do not recommend wireless for internet intensive gaming. It's just one more thing that can go wrong.

Having an open NAT (or a UPnP router) won't solve all party, matchmaking, connectivity, or other issues you may be experiencing. It will help, and certainly won't hurt.

See if XBM says that UPnP is allowed. If it is not allowed, you should have realistic expectations. At this point, you are at the mercy of the other clients to send you information.

Check in the party lobby or the MP -> Options -> <Select button> what the NAT type is.

Last but not least. A solid UPnP router is just one way to get an OPEN NAT. Port fowarding and/or a DMZ are other viable options, but getting into those are outside the scope of this already massively long post.
Psn- David_OS, Xyour-ambitionX

User Info: UR_DEAD

10 years ago#6
i dont have time to read it all right now, but if i went back later and read it what would i learn? so what is this about? improve conection thru nat type?
PSN: x_Magee_x Founder of Clan: oWn?
Black Ops: 2.2 kdr 1.4 wlr

User Info: dawnnoob

10 years ago#7
Well it seems most people are having nat type problems, this is a solution to find out how to change the nat type or finding the problem.
Psn- David_OS, Xyour-ambitionX

User Info: mrhemmo

10 years ago#8

easy way to solve this (at least it was for me ) is DMZ.Just googleps3 to dmz there is great and easy afterdawns step by step instructions.

User Info: valdin_450

10 years ago#9
requesting a sticky. this is great info.
PSN ID: xTCFxBONE5 | Xbox Live: valdin450
Steam ID: valdin450

User Info: jzzy107

10 years ago#10
I have had a static IP and DMZ host to that IP for over a year. I still have NAT Type Moderate in BO. I may try the UPnP option but I am sure that has always been enabled.

Funny when I turned off the "Load MP by default" option I got NAT Type Open but that lasted until the next PS3 reset.

I have Verizon FIOS with the standard Actiontec Router. May try to reset the router hopefully that will help.
PSN: hilz
  • Topic Archived

GameFAQs Q&A