• Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.

User Info: snowstorm52

snowstorm52
10 years ago#1
I just bought this game used at Gamestop and there's no scratches or anything on the disc or casing, but I'm having a problem.

I finished the first city and killed the spider boss. I got permission to leave the city to head to the first location you visit outside the city gates. However, every time I try to leave the city, the game doesn't load. It goes to the loading screen, you hear the disc spin one time in the system, then the system goes quiet while the loading screen is still animated on the bottom. I have let the system sit for over 5 minutes loading, as well as reloading my save and trying to exit again several times, yet I cannot leave Aven because the game won't load the world map or over world or whatever this game has.

Is it supposed to take so long to load the first area outside the city? Is there something wrong with my copy? My receipt expires tomorrow, so if there's something wrong, I need to return the game soon or Gamestop won't take it back. Someone please help me out.

User Info: BloodRayne52868

BloodRayne52868
10 years ago#2
The load time doesn\'t sound right to me, try exchanging it for another copy. If the new copy does the same thing, then I hate to say it but there is probably something wrong with the psp itself.

--- (+[___]+) ~UMD\'s Owned.....141 Games.....49 Movies~I\'m not a dude I\'m a grrrl gamer~

User Info: snowstorm52

snowstorm52
10 years ago#3
I tried the game out again and still a no go. Everything within Aven loads and plays fine. But any time I try to leave the city the system stops reading the disc. Those lines on the bottom of the screen keep moving though and the system isn't freezing so that's what has me confused.

I know it's not the system because everything else I own works perfectly. It's just this game. Guess I'm going to return the game then because I bought the last copy my local GS had in stock. This is why I hate buying used games because I almost always run into a problem with them.


Would it make a difference if I turn off the cache? I just thought of that now. Is this game known to have problems with newer model PSPs since it's a launch title? My fat broke awhile back and I upgraded to a slim 3000 when GS had a good trade in program going on last year that got me this new system for less than half price, still cheaper than Sony's repair charge.

User Info: BloodRayne52868

BloodRayne52868
10 years ago#4
I buy used from gamestop all the time, I almost never have problems with a game. To answer your question, as far as I know the cache isn\'t an issue, I have a 2000 & 3000 model & the game works fine in both.

--- (+[___]+) ~UMD\'s Owned.....141 Games.....49 Movies~I\'m not a dude I\'m a grrrl gamer~

User Info: snowstorm52

snowstorm52
10 years ago#5
I tried the cache thing and it didn't work like you said. I wound up returning the game. I really enjoyed what little I was able to play though so I'll probably pick the game up again over the summer and hope I get better luck. Between Final Fantasy 13, God of War 3, Star Ocean Last Hope International, and the upcoming GTA 4 expansion packs, I've got plenty to keep me busy. Plus I got Lunar in the mail today for PSP from Amazon. Gonna just hang onto my game save and hopefully start this game up again in a few months. I'm gonna look for it in the $6 price range since that's what I paid Gamestop earlier in the week.
  • Topic Archived

GameFAQs Q&A