• Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. BioShock
  3. Bioshock won't run anymore after some time

User Info: dullian

dullian
7 years ago#1
I've read about the issues when running Bioshock on Windows 7, I guess that's my problem but the solutions I've looked up on the internet haven't worked (stereo mix, right click > compatibility).

To start with, I'm perfectly able to install and run the game, no errors happen when playing, everything runs smoothly. However, after some time, usually the next day after installing the game, I click on the icon to launch the game but nothing happens, the splash screen fails to appear, the only thing that starts is the Bioshock*32.exe process (and, since I'm on a x64 bits system, I'm not sure if it's okay for the process to be labeled 32, not sure if it has anything to do with the program's architecture version).

The only way to fix this so is to uninstall and reinstall the game, but it'd be such a pain if I were to do that every time I wanted to play.
I don't think it's a hardware problem, so let's rule that out. I can run other games without any problem. My system has an Intel i5 3570 K 3.40 ghz cpu, 4 gb ddr 3 ram and, not ashamed to say it, I'm using my cpu integrated graphics, Intel HD graphics 4000 by now, which, by the way, allow me to set Bioshock to the maximum level of detail without any setbacks.

What should I do to solve this? A friend of mine could run the game without any issues, his system has a different Windows 7 version, while mine has Windows 7 Ultimate.

User Info: dullian

dullian
7 years ago#2
Well, I was able to solve this.
First, I made a fresh installation of the game, then I compressed a backup of the Bishock executable file.
When the game won't start up, I just delete the Bioshock.exe from the Release folder inside the directory I installed the game in. After that, I run the registry file inside the same directory. Finally, I extract the game's executable file previously compressed from the fresh installation, obviously I extract the .exe file to the Release folder. That's all.

User Info: lilazndevildude

lilazndevildude
7 years ago#3
had the same problem crash on the bioshock shock logo

i have window 7 ultimate for me i fix by

going to Local C > Programs x32 > Steam >Steamapp>common>Bioshock>Build>release>bioshock.exe

right click
properties
comptability
tick mark Run this program
n choose Windows 2000

hope this helps
..................................................

if fails

then u have to turn off the sounds in Bioshock open up Steam program
Steam
Bioshock>right click properties
click Set launch option
type in -nosound

it will turn off the sounds. there will be NO SOUND as u play
3DS FC: 1177-7109-6325, Trainer name: Red
  1. Boards
  2. BioShock
  3. Bioshock won't run anymore after some time
  • Topic Archived

GameFAQs Q&A