• Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.

User Info: Cookiethievery

Cookiethievery
5 years ago#1
Title says it all.

I installed the GOG version the other day on windows 8.1, patched up to the most current date, installed the unofficial patch, installed the high-rez pack, added -no3d and -doublebuffer to the shortcut, and the game starts to lag/slowdown like hell after about 5-15 minutes. Went back and removed the -no3d and -doublebuffer from the shortcut and tried several other variants. I even uninstalled the game completely, and just installed the official patch and omitted the last few steps with the same effect, with crappy graphics and bugs galore.

Has anyone had a similar experience? If so, what worked for you?

User Info: Wygun

Wygun
5 years ago#2
Same thing for me, the game works like crap in my win8 laptop, the no3d didnt help either. Works fine in my win7 desktop thogh. Weird since fallout 2 and morrowind dont have any problems in win8.

User Info: Coontemptus

Coontemptus
5 years ago#3
I have an original release version, and it always ran fine if I just ran the game in compatibility mode.
You chose to be a scumbag, by making your character a murderer of the innocent.
You are a sinner. And I'm here to even the score.

User Info: Cookiethievery

Cookiethievery
5 years ago#4
Might have found a workaround, it worked for me (somewhat), hopefully it will work for others. Found the solution here from the user Hozuko at the bottom post:

http://www.gog.com/forum/arcanum_of_steamworks_and_magick_obscura/arcanum_windows_8_issues_lag/page2

Anyways, you first d/l ddwrapper.zip (google it) and extract it all to your arcanum folder. Open the aqrit.cfg with notepad and change the ForceDirectDrawEmulation to 1 or 2. I haven't tried changing it to 1 yet, but I have significant improvement with 2. You have to make sure you have the -no3d added to your shortcut or it will crash to desktop on startup.

It isn't a 100% fix, it still slows down here and there, but not to the point of being near-unplayable like before. I will try the ForceDrawSetting at 1 and see how it runs.

User Info: Fizzle_Pork

Fizzle_Pork
5 years ago#5
I know it doesn't fix the problem for those with only one PC, but this is precisely why I keep every PC I've ever had. That way I can play the latest and greatest titles on my modern machine, but still fire up a game like this without worry.

User Info: Cookiethievery

Cookiethievery
5 years ago#6
Coontemptus posted...
I have an original release version, and it always ran fine if I just ran the game in compatibility mode.


What is the original release version? Like the original patched to the latest without the unofficial patch by drog? Which compatibility mode did you try? I've tried it with XP, windows 7, Win 95 and keep getting the slowdown, even with the trick I mentioned earlier about the ddwrapper file which did speed my game up to a normal speed, but it slows down to a crawl after 10 minutes, every time, without fail.

User Info: Fizzle_Pork

Fizzle_Pork
5 years ago#7
Does your PC have an integrated graphics controller besides whatever graphics card you have? If so, open your graphics card settings and manually set Arcanum to run off of integrated.

User Info: Coontemptus

Coontemptus
5 years ago#8
XP, current unofficial patch.

I can also play it just fine on my Win7 machine.
You chose to be a scumbag, by making your character a murderer of the innocent.
You are a sinner. And I'm here to even the score.

User Info: The_alchemy1356

The_alchemy1356
5 years ago#9
I know it doesn't fix the problem for those with only one PC, but this is precisely why I keep every PC I've ever had. That way I can play the latest and greatest titles on my modern machine, but still fire up a game like this without worry.

It's really good to see that I am not the only one who practice this :) I can tell you how fortunate I feel whenever i wanted to play an older game on the newer machines but the newer machines (with all the supposed new improved features on it) can't support it. Proceeding to play it on my older machines and all the problems gone in an instant.

To the OP, i hope that you can get the game working, or else you'll miss out on this one great gem of a CRPG.
Big Smoke: "All we had to do, was follow the damn train, CJ!"
CJ: "Yeah, and all you had to do, was hitting the damn target, Big Smoke!"

User Info: Cookiethievery

Cookiethievery
5 years ago#10
The_alchemy1356 posted...


To the OP, i hope that you can get the game working, or else you'll miss out on this one great gem of a CRPG.


Oh I played this when it first came out when I was younger, but I didn't really get into it until a few years back. I was able to finally get it working, with the other changes I mentioned, but I actually had to take out the -no3d and the -doublebuffer and put in -window and it runs smooth as butter with no slowdown...that is really the only way I could get it working. I can deal with the window border at the bottom but that horrid lag, no way.
  • Topic Archived