• Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Final Fantasy XIV Online: A Realm Reborn
  3. Anyone else having connection issues.

User Info: UltimaKitty

UltimaKitty
1 month ago#1
I just bought the complete edition and made my new character in limsa. Well now I can't do anything because everytime I try to get a quest I disconnect.

I played the trial before so I know I have the right specs. My other online games are working fine. But this isn't. The world I'm in is leviathan if that matters.
Please stop reading this signature

User Info: Dethuli

Dethuli
1 month ago#2
PS4 or PC? Ethernet or Wi-Fi? Error code?
Don't ask questions. Consume product. Get excited for next product.

User Info: panforis

panforis
1 month ago#3
Many things could affect that including how full your server is, your connection speed/strength, and if PSN is having issues.

If you played the free trial fine on the same device I would think it might be one of these or something similar.

User Info: Shadygrove

Shadygrove
1 month ago#4
I have but the problems were all on my end.
There are only two things that may be infinite. The universe and human stupidity. I am not sure about the universe. - Albert Einstein

User Info: kuter

kuter
1 month ago#5
Shadygrove posted...
I have but the problems were all on my end.
I had a similar issue before, rubberband, lag spike, was really annoying on 14 (I was owning everyone in cod due to that though lol), so i called my isp and my modem was losing 35% of its signal, once they rebooted it i had no more lag (I went back to 50/50 on cod lol)
  1. Boards
  2. Final Fantasy XIV Online: A Realm Reborn
  3. Anyone else having connection issues.
  • Topic Archived

Need More Help?

  1. Guides and Walkthroughs 5 Guides / Maps
  2. GameFAQs Q&A 190 Questions (189 Answered)

GameFAQs Q&A