House Wing Additions glitch and work around

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. House Wing Additions glitch and work around

User Info: duke2go

6 months ago#1
So first I'll say I'm sorry if this was already covered, but I couldn't find any helpful info in my searches, so wanted to save other people a headache. Second, don't try to build 2 houses at once!!! I'm 90% sure that's how I caused my issue.

So I only had Lakeview Manor before all this happened. I built the library (which I don't really recommend) and kinda just left the house alone while I thought about what other wings I wanted to build there. Thought Lakeview was the only house I could build in my ignorance. So, when I found out I could build 2 more houses I was like "well I'll go do that and kill a few hours". Wanted to build 3 different places with unique additions. After playing Fallout 3 and NV on PS3 I honestly should have known better.

So I did all I needed to for Windstad Manor and went and built the small house, main hall, and all additions (chose the kitchen, another mistake, the storage and the bedrooms for the wrap around porch where there is an actual view. I took the kitchen just because that side had a mountain, so no real "view"). House built fine, though the workbenches were screwy, which I'll explain better later. Wrote it off and moved on to the final property.

So then I went and did the quest for Heljarchen Hall and it bugged on me when I started building. Simple reload seemed to fix that. Built up to the main hall and added the armory (which amazingly has been rather stable so far) but then when I went to build more wings, all I had available at the drafting table was build small house. Tried reloading, same issue. Tried looking at the table multiple times and eventually I got options to remove workbenches, but no plans for other wings. Nothing I did would let me build new wings. I wrote it off and kept playing, figuring the game would fix itself, it didn't. Tried removing game data and reinstalling, didn't work.

So finally today I saved my game, got all my supplies together, walked out of the Heljarchen Hall, went to the drafting table, and when it gave me the option to start building the small house, I selected it and started building. Got done, got option for main hall, kept going. Finally, after basically rebuilding the damned house, I got the options to build wings again. Built the trophy room, watched it go up, saved, and went inside. Sure enough, the game registered it was built, but it closed off my armory because it thought it rebuilt the walls. Went back outside, had the option only for small house...

Reloaded the save after I built the trophy room, checked the drafting table a few times, and eventually got plans for additional wings again. Rebuilt the armory and built the alchemists tower before going back in the house (the armory was still actually visible outside, but no doors to get in). So I go in and voila!!! All 3 rooms, and the stuff in the armory was actually still where I left it.

Now I have to admit all of the house workbenches have been bugged since all this started and I keep getting options to build stuff that's already there, though if I exit the table and go back in a few times it normally fixes itself and catches up. Also, having the steward "furnish" the rooms no longer works it seems, but I can still do things manually, so I guess it still counts. It is expensive to do it this way, but since its a console version, there didn't seem to be a better fix that I could find.

Long story short, build each house completely before you get another and I doubt you'll have an issue. Be overzealous like me and be prepared to have incomplete houses, or spend a bunch of gold building a house twice... Now I have to see if it will work at Lakeview...

Hope this helps other people having similar issues.
(message deleted)

User Info: duke2go

6 months ago#3
I was eventually able to do the same thing at Lakeview, though it took a few tries. The game has a habit of taking out something important to finishing the addition. Like the ability to build walls. So when I rebuilt the library, it missed a part and kept the doors like a portal back to skyrim. Except in an unfurnished library tower. I reloaded from square 1, built the small house, main hall, greenhouse, and storage room (for the actual "lake view") the 2nd time before rebuilding the library and waiting a fair amount of time outside before going back in. The game added a few workbenches but I've more or less been able to remove them. Like I said, don't build a new house until you finished the first and this hopefully won't be an issue. Ot was expensive buying materials twice I know that. Hope this helps other PS3 players.

User Info: Alessar

6 months ago#4
duke2go posted...
chose the kitchen, another mistake,

No it wasn't. The kitchen - specifically the oven - allows you to make certain foods you can only get that way. For instance, garlic bread. Bread + butter + garlic and you get a 0.1 weight food item that cures all diseases. There's a couple other niche food buffs available too.
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. House Wing Additions glitch and work around

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

Update Topic Flair

You are not allowed to update this topic's flair.

  • Topic Archived