TCP/IP Cannot Connect Since Patch 1.12

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Diablo II: Lord of Destruction
  3. TCP/IP Cannot Connect Since Patch 1.12

User Info: bandoth

bandoth
9 years ago#1

I'm currently experiencing a problem with the new patch. My friends wish to play Diablo with me via TCP/IP connections, rather than bnet. Unfortunately, we discovered that the one person who we hadn't been in touch with recently had already updated to this version of the patch. With the rest of us sporting 1.11b copies, we decided to update. This is where the problems arose.

One friend of mine has a Windows ME computer, mine a Windows XP. Prior to the 1.12 patch I was able to host and he able to join just fine, due to my port forwarding as directed on Bnet support forums. However, after experiencing problems updating the Windows ME computer and solving said problems, my friend is now able to run Diablo 2, connect to Bnet, and make every aspect of the game work that should work. But he can no longer connect to my hosted TCP/IP games.

It is not an issue of port forwarding. I have checked my router/firewall settings and they are fine. My friend can even join my Ventrilo server, but whenever he attempts to connect to my TCP/IP game, he receives a message informing him that he was unable to connect to the server. Hamachi will not work either as it is not supported for Windows ME. Does anyone have any ideas? They would be greatly appreciated.

User Info: Phieeel

Phieeel
9 years ago#2
Has your friend been able to join a TCP/IP game hosted elsewhere?
You have no proof there aren't purple gremlins in my basement.-LLLL
~Saint of AC:Last Raven board~

User Info: bandoth

bandoth
9 years ago#3
We have not yet been able to try. We will try it as soon as possible (the only other person who knows how to set up his computer to do so lives halfway around the globe. Literally).

User Info: Glamthaus

Glamthaus
9 years ago#4
1. Turn off both your firewall and your friends firewall, and try again. This will immediately establish if it is a firewall issue or not.

2. Check your port forward settings again. It should be:
TCP and UDP for ports 6112 - 6119
TCP for port 4000

3. Make sure you're giving your friend your external IP address and not your internal. The website Whatismyip is a good way to check what your external IP address is.

4. If the above doesn't work, something funky is going on that I cannot explain.

User Info: bandoth

bandoth
9 years ago#5
Oh? It's known to shift between those ports? I was under the impression that only 6112 and 4000 needed to be open with their respective settings.
  1. Boards
  2. Diablo II: Lord of Destruction
  3. TCP/IP Cannot Connect Since Patch 1.12

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived