Weapon upgrades

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. LEGO Dimensions
  3. Weapon upgrades

User Info: Lexandra1

Lexandra1
11 months ago#1
Hello folks, since I haven't seen it anywhere, well there I go.
So I've collected enough (finally got that 1 million studs for the x2 brick) to fully upgrade almost everything, well all vehicles, and almost all gadgets, anyway by fully upgraded, I mean everything except the Chrome armor (is it really an armor, or just a chrome paintjob?), I don't really need that and it costs 1 million of studs on every model, so I'll pass. But what bugs me, are the upgraded weapons. Is there a way to turn them off? I turned them off initially after buying them in the Vorton computer, but for some reason, they are always on. Everytime I put a vehicle on the portal pad, the upgraded weapons (the icon on the bottom of the circular in-vehicle menu is blue) are on. I can turn them off from that menu, but everytime I bring that vehicle in (even calling it through the circular menu and also after any cutscene) it just resets the weapons. Everything else stays, I can change skins, or save the model builds, it saves all nicely, but the weapons don't. Why does it bug me? Because it's annoying to turn them off manually everytime. And why I bother to turn them off, why not leaving them on? Some models have better weapons (or abilities) in their model builds, and this overrides it. The Ultra Time Machine (3rd build of the DeLorean) has those nice target seeking rockets, while the upgraded weapons (same for every model) fire just straight line. The 3rd TARDIS build has that force field, that catches nearby enemies. This is not that bad as for the field, I have to hold the square button, it works even with the upgraded weapons on, but even though one simple press of that button still fires a misile (for example if I press that button by mistake).
Also for the role play. The Batmobile should have its weapons initially disabled and everytime you need ehm some sort of "battle mode" (to shoot some obstackle on the road or anything), you would have to activate the weapons first, then shoot them. Not just jump into a to the teeth armed beast from the start.
Do they seriously believe, they can defeat us? We'll teach them, why the Jem Hadar are the most feared soldiers in the Dominion. For the Founders!

User Info: Xeowulf

Xeowulf
11 months ago#2
If you're re-save the model after you turn them off and they're still on, you're game is glitching. It happens. A lot.

And it wouldn't cost a million studs to upgrade every model if you had the A-Team pack. ;) That red brick (I Know A Guy) halves the vehicle cost.
I could care less about grammar.

User Info: Darkling183

Darkling183
11 months ago#3
Xeowulf posted...
If you're re-save the model after you turn them off and they're still on, your game is glitching. It happens. A lot.

I just experimented with the Batmobile and the DeLorean, and even if I turn off the "colour changing bolts" weapon in the upgrade menu and write to the tag, that ability is always still enabled when I put the vehicle back on the pad. It must be a glitch.

User Info: Xeowulf

Xeowulf
11 months ago#4
Darkling183 posted...
Xeowulf posted...
If you're re-save the model after you turn them off and they're still on, your game is glitching. It happens. A lot.

I just experimented with the Batmobile and the DeLorean, and even if I turn off the "colour changing bolts" weapon in the upgrade menu and write to the tag, that ability is always still enabled when I put the vehicle back on the pad. It must be a glitch.

Sometimes if you change the vehicle to a different model, save, go back into edit mode and change what you want, change it back to the model you want, and save again that it'll typically hold changes better.
I could care less about grammar.

User Info: Darkling183

Darkling183
11 months ago#5
I guess it's just something that Dimensions players are going to have to live with, since I doubt Tt will be releasing any more non-essential updates to the game. =/

User Info: Lexandra1

Lexandra1
11 months ago#6
Darkling183 posted...
Xeowulf posted...
If you're re-save the model after you turn them off and they're still on, your game is glitching. It happens. A lot.

I just experimented with the Batmobile and the DeLorean, and even if I turn off the "colour changing bolts" weapon in the upgrade menu and write to the tag, that ability is always still enabled when I put the vehicle back on the pad. It must be a glitch.


That's exactly, what I mean. I'm not the best at explaining things, but it is that "colour changing bolts" upgrade/thing (the blue icon in the vehicle abilities menu - holding down the circle button). It is always on, when I place the toy on the portal pad, it resets to the "on" state whenever I call the vehicle through the characters menu (holding triangle), and it resets after every cutscene back to the "on" state, when I turned it off earlier.

If it's a glitch, then it shouldn't happen everytime, glitches are supposed to happen from times to times, or under certain circumstances. I think, it's intentional. And that's, what bugs me the most. It happens everytime and I have to turn it off manually.
Do they seriously believe, they can defeat us? We'll teach them, why the Jem Hadar are the most feared soldiers in the Dominion. For the Founders!

User Info: Lexandra1

Lexandra1
11 months ago#7
Xeowulf posted...
Darkling183 posted...
Xeowulf posted...
If you're re-save the model after you turn them off and they're still on, your game is glitching. It happens. A lot.

I just experimented with the Batmobile and the DeLorean, and even if I turn off the "colour changing bolts" weapon in the upgrade menu and write to the tag, that ability is always still enabled when I put the vehicle back on the pad. It must be a glitch.

Sometimes if you change the vehicle to a different model, save, go back into edit mode and change what you want, change it back to the model you want, and save again that it'll typically hold changes better.


I am doing that a lot, while trying different skins, changing the skin, save the model, looking at it, change the build, save (I'm saving the models a lot), looking at the new model, changing to the last build with the current skin on. But the "colour changing bolt" thing is always on, when I bring the model next time in. It doesn't help to change and save everything everytime. If this upgrade wasn't needed, I wouldn't even bother to buy it, but unfortunately, you need to buy it to unlock the next upgrade in the row.
Do they seriously believe, they can defeat us? We'll teach them, why the Jem Hadar are the most feared soldiers in the Dominion. For the Founders!

User Info: MrBeens

MrBeens
11 months ago#8
Ok, I know this is super patronizing given everything discussed here already, but just to be absolutely crystal clear:

If you are in the upgrade menu make sure the color changing bolt upgrade has the color red above it when you select it, which means it's disabled. If it has the green color above it, then it is on.

After verifying it is red, press triangle to save the settings to the toy tag. This should save it in the disabled configuration, so every time you put the vehicle on the pad it should load in the disabled configuration.

If this isn't working then unfortunately it's a bug, and there probably isn't anything you can do about it.

User Info: Darkling183

Darkling183
11 months ago#9
MrBeens posted...
If you are in the upgrade menu make sure the color changing bolt upgrade has the color red above it when you select it, which means it's disabled. If it has the green color above it, then it is on.

After verifying it is red, press triangle to save the settings to the toy tag. This should save it in the disabled configuration, so every time you put the vehicle on the pad it should load in the disabled configuration.

If this isn't working then unfortunately it's a bug, and there probably isn't anything you can do about it.

That's what I've been doing. (I don't know about Lexandra.) I haven't tried Xeowulf's idea about changing the build first, though.

At least it's not a significant bug like the 1015 out of 1016 gold bricks glitch. I personally don't mind if the colour-changing bolts are always active.

User Info: Lexandra1

Lexandra1
11 months ago#10
MrBeens posted...
Ok, I know this is super patronizing given everything discussed here already, but just to be absolutely crystal clear:

If you are in the upgrade menu make sure the color changing bolt upgrade has the color red above it when you select it, which means it's disabled. If it has the green color above it, then it is on.

After verifying it is red, press triangle to save the settings to the toy tag. This should save it in the disabled configuration, so every time you put the vehicle on the pad it should load in the disabled configuration.

If this isn't working then unfortunately it's a bug, and there probably isn't anything you can do about it.


I've wrote, that I turned them off initially after buying them (the indicator is red). While the other similar upgrades save in the "off" state, be it the alternate skins, swarm weapon, mine weapon, the explode ability, or the speaker attack, everything saves nicely (even this "colour changing bolt" saves as off, with the red indicator above it), but only this one is on when putting the toy on the portal pad. Everything else works, as it should.

I wouldn't mind it, if this was better, than the initial weapons of certain builds, but it isn't. Some models in their next build get better weapons, like the Ultra Time Machine. Or even the Electric Time Machine, the upgraded weapons override this, they shoot in a straight line, the electric DeLo looses it's electric attack, and the distant attack (shooting electric bolts in a distance, this allows to charge those generators remotely, sometimes you can't get close enough to where you need to charge, and this helps greatly). To get all that back, I have to disable the upgraded weapons manually. And it resets, when a cutscene plays, or when the vehicle is far too away and I want to call it to me. Again the need to manually turn the weapon upgrades off, everytime.
Do they seriously believe, they can defeat us? We'll teach them, why the Jem Hadar are the most feared soldiers in the Dominion. For the Founders!
  1. Boards
  2. LEGO Dimensions
  3. Weapon upgrades

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

Update Topic Flair

You are not allowed to update this topic's flair.

  • Topic Archived